1. Es freut uns dass du in unser Minecraft Forum gefunden hast. Hier kannst du mit über 130.000 Minecraft Fans über Minecraft diskutieren, Fragen stellen und anderen helfen. In diesem Minecraft Forum kannst du auch nach Teammitgliedern, Administratoren, Moderatoren , Supporter oder Sponsoren suchen. Gerne kannst du im Offtopic Bereich unseres Minecraft Forums auch über nicht Minecraft spezifische Themen reden. Wir hoffen dir gefällt es in unserem Minecraft Forum!

NullPointerExeption

Dieses Thema im Forum "Programmierung" wurde erstellt von Nickie, 12. November 2013.


  1. Nickie
    Offline

    Nickie Guest

    Hey Leute ich hoffe ihr habt ein wenig ahnung vom programmieren von android apps wenn nicht würde ich bitten diesen code trotzdem nochmal anzuschauen. immer wenn ich die app starte kommt ein NullPointerExeption Fehler aber wie kann ich den beheben


    code: http://pastebin.com/wHZE0UWA



    Fehlercode: http://pastebin.com/9cU4jVmR
     
    Zuletzt von einem Moderator bearbeitet: 12. November 2013
  2. Chrisliebaer
    Offline

    Chrisliebaer Guest

    Und jetzt postest du noch die Exception mit Zeilennummer und allem was dazu gehört. So kann dir keiner helfen.

    Code (Text):
    1. 11-12 18:27:21.059: E/AndroidRuntime(772):  at com.dornickie.dornickie.MainActivity.onCreate(MainActivity.java:24)
    Da du aber vermutlich das Package entfernt hast stimmt die Zeilennummer nichtmehr. Poste bitte die komplette Datei ohne abgeschnittene Teile oder zensier halt das Zeugs, das du nicht öffentlich posten willst.
     
    Zuletzt von einem Moderator bearbeitet: 12. November 2013
  3. Nickie
    Offline

    Nickie Guest

    hab ich,und jetzt?

    - - - Aktualisiert - - -



    kein Problem: http://pastebin.com/vPbbJwen
     
    Zuletzt von einem Moderator bearbeitet: 12. November 2013
  4. Chrisliebaer
    Offline

    Chrisliebaer Guest

    Das sieht so als, als hättest du nicht das richtige Layout gesetzt.

    Code (Text):
    1. setContentView(R.layout.viewpager_layout);
    Gibt es wirklcih die Elemente mit den von dir angegebenen IDs in genau diesem Layout?

    Die 2. Möglichkeit wäre, dass deine Anwendung vielleicht keine Berechtigungen für den Internetzugriff hat.
    http://stackoverflow.com/questions/15476601/android-webview-nullpointerexception.

    Du könntest allerdings auch mal mit dem Debugger gucken, was da genau passiert.
    http://developer.android.com/tools/debugging/debugging-projects.html
     
  5. Nickie
    Offline

    Nickie Guest


    ok danke, dass Problem war wirklich dass die Anwendung keinen Internetzugriff hat.