Plugin Fehler, bitte um Hilfe

Dieses Thema im Forum "Programmierung" wurde erstellt von Silvergreen, 20. September 2015.

  1. Silvergreen
    Offline

    Silvergreen

    Registriert seit:
    20. September 2015
    Beiträge:
    4
    Hallo Community,
    ich habe schon echt viel im internet herrumgesucht, aber nie etwas gefunden. Irgendwann bin ich dann auf diese Websie gestoßen wo einer dann das gleiche problem hatte, aber die lösung war doch eine andere. Naja, genug um den heißen Brei geredet. Es geht darum, dass ich letztens ein Plugin gesucht hatte, habe dann ein Super Tutorial gefunden, und alles wie der Youtuber eingetippt. Da er aber weniger eintippen musste als ich, da es ein Tab Plugin werden sollte und ich noch etliche Gruppen mehr haben wollte... Naja da liegt warscheinlich eh nicht der Fehler. Ich habe meine beiden Dateien als Anhänge hinzugefügt, der dritte Anhang ist die Fehlermeldung. Fals ihr nochetwas benötigt, lasst es mich wissen.

    Mfg Silvergreen
     

    Anhänge:

    #1
  2. Matthias
    Offline

    Matthias Administrator

    Registriert seit:
    6. Juli 2011
    Beiträge:
    1.138
    Ort:
    Franken
    Die Fehlermeldung ist recht deutlich:

    main class `tabpackage.tabclass' does not extend JavaPlugin

    D.h. du musst noch eine Vererbung einbauen, ich kenne die Java Syntax dafür jedoch nicht.
     
    #2
  3. Silvergreen
    Offline

    Silvergreen

    Registriert seit:
    20. September 2015
    Beiträge:
    4
    Und wie mache ich so eine Vererbung?
    Kenne mich nicht so damit aus
     
    #3
  4. GPSforLEGENDS
    Offline

    GPSforLEGENDS

    Registriert seit:
    21. März 2014
    Beiträge:
    295
    Ort:
    Bürostuhl
    Minecraft:
    GPSforLEGENDS
    ... -.-
    Die Vererbung wird selbst der Youtuber gemacht haben.
    Also guck dir doch einfach sein Video an und "tipp Alles genauso ein" oder Google einfach Java Vererbung
     
    #4
  5. Kevin060901
    Offline

    Kevin060901

    Registriert seit:
    1. April 2014
    Beiträge:
    1
    Hi Silvergreen

    Das Problem liegt daran das der Server das Plugin nicht erkennt als plugin.

    Weil:

    Bei dir steht:

    public class tabclass implements CommandExecutor

    Hier weiß aber der Server nicht das das ein Plugin ist.

    Mach es so dann müsste es gehen

    public class tabclass extends JavaPlugin implements CommandExecutor

    Durch das extends JavaPlugin erkennt es der Server.
     
    #5