>>Programmier-Fehler ?<<

Dieses Thema im Forum "Programmierung" wurde erstellt von Cube-Player, 12. April 2013.

  1. Cube-Player
    Offline

    Cube-Player

    Registriert seit:
    26. März 2013
    Beiträge:
    21
    Ort:
    NRW
    Minecraft:
    instruction19
    Hallo Liebe

    Community.


    >>Programmier-Fehler ?<<

    Ich habe erst vor kurzem angefangen plugins zu schreiben.
    Daher habe ich mir ein Video angesehen.
    habe auch Leicht angefangen, und zwar "/hallo".
    Wenn man dann "/hallo" eingegeben hat kommt zurück "Moin".
    Aber leider hat es nicht Funktioniert.

    >>Problem<<

    Wo ich das plugin in meinen Test-Server, Per Drag&Drop reingezogen habe
    war das Plugin zwar drinn aber 1. hat der Command nicht Funktioniert und
    2. Stand bei "/help" nicht das plugin drinn und welche Funktion es hat.

    ______________
    >>Code-Folgt<<
    ______________



    Liebe Grüße.
    CubePlayer
     
    #1
  2. Kubbelie
    Offline

    Kubbelie

    Registriert seit:
    10. Oktober 2012
    Beiträge:
    86
    Ohne Fehlermeldungen und den Logs in der Konsole, ist dieser Thread ein Hoffnungsloser Fall.
     
    #2
  3. games6471
    Offline

    games6471

    Hattest du eine fehlerfreie plugin.yml?

    Hast du den Befehl in diese eingetragen?

    Stimmt der Pfad zur Main-Klasse?

    //Bei help steht das Plugin nur drinnen, wenn es einen gültigen Befehl registiert ansonsten steht es nur in der normalen Pluginliste drinnen (/pl, /plugins).

    //Bitte schreibe normal.
     
    #3
  4. rBxGame
    Offline

    rBxGame Ehem. Teammitglied

    Registriert seit:
    16. Februar 2012
    Beiträge:
    1.077
    Aber immerhin schön, dass du schon einmal
    den Thread erstellt hast...
    welcher ohne Fehler bzw. Source total nutzlos ist.

    Also schreib uns mal bitte die Codes...


    Ich bitte auch darum!

    MFG
    rBx
     
    #4
  5. Cube-Player
    Offline

    Cube-Player

    Registriert seit:
    26. März 2013
    Beiträge:
    21
    Ort:
    NRW
    Minecraft:
    instruction19
    Ich habe mir das Video knapp 5 mal angeschaut.
    Habe alles befolgt was gesagt wurde.
    Plugin.yml müsste auch alles richtig sein.
    Also "<commands>: /hallo


    Liebe Grüße.
    CubePlayer
     
    #5
  6. rBxGame
    Offline

    rBxGame Ehem. Teammitglied

    Registriert seit:
    16. Februar 2012
    Beiträge:
    1.077
    Gut, dass du das Video 5 mal geschaut hast, unsere
    Beiträge aber nicht einmal ...

    Wir benötigen deinen Source und eventuelle Fehlermeldungen!
    Sonsts wirds schwierig, dir zu helfen.

    Btw: Ich würde mit den Grundlagen von Java anfangen. Und hierzu ein
    Buch statt Video-Tutorials nutzen


    MFG
    rBx
     
    #6
  7. games6471
    Offline

    games6471

    Am besten auch die plugin.yml als komplette Datei hochladen.
     
    #7
  8. Cube-Player
    Offline

    Cube-Player

    Registriert seit:
    26. März 2013
    Beiträge:
    21
    Ort:
    NRW
    Minecraft:
    instruction19
    &gt;&gt;Programmier-Fehler ?&lt;&lt;

    Leider bin ich auf dem Mobilgerät online deswegen auch
    >>Code-Folgt<<
    Aber ein buch habe ich mir schon gestern bestellt und kommt morgen an.




    Liebe Grüße.
    CubePlayer

    - - - Aktualisiert - - -

    Ich werde die Plugin.yml auch hochladen



    Liebe Grüße.
    CubePlayer
     
    #8
  9. games6471
    Offline

    games6471

    Eine Frage, die mich stark interessiert: Warum schreibst du nicht normal? Eine solche Formatierung des Text, welche du verwendest, ist meiner Meinung nach unschön als Standart zu benutzen.
     
    #9
  10. Cube-Player
    Offline

    Cube-Player

    Registriert seit:
    26. März 2013
    Beiträge:
    21
    Ort:
    NRW
    Minecraft:
    instruction19
    Werde ich zu kentniss nehmen nicht
    mehr mit Formatierung zu schreiben.



    >>Liebe Grüße.<<
    >>CubePlayer<<
     
    #10
  11. Kubbelie
    Offline

    Kubbelie

    Registriert seit:
    10. Oktober 2012
    Beiträge:
    86
    *Kopf schüttel*
     
    #11
    1 Person gefällt das.