Sentry Plugin wo liegt der fehler?

Dieses Thema im Forum "Server Plugins" wurde erstellt von Skydorm, 19. Juni 2014.

  1. Skydorm
    Offline

    Skydorm

    Registriert seit:
    23. Mai 2014
    Beiträge:
    36
    Hallo Leute. Ich hoffe ihr kennt euch mit programmieren aus, oder zumindest mit dem programm. Ich hab ein Citizens ,und wollte noch ein Sentry-Citizens Plugin installieren. Dass hab ich auch getan, doch jetzt kommt immer der gleiche fehler wenn ich /trait sentry mache.

    Hier ist mal Der Fehler der Console.

    19.06 16:22:55 [Server] INFO [16:22:55 WARN]: ... 28 more
    19.06 16:22:55 [Server] INFO [16:22:55 WARN]: at java.lang.ClassLoader.loadClass(ClassLoader.java:358)
    19.06 16:22:55 [Server] INFO [16:22:55 WARN]: at java.lang.ClassLoader.loadClass(ClassLoader.java:425)
    19.06 16:22:55 [Server] INFO [16:22:55 WARN]: at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:62)
    19.06 16:22:55 [Server] INFO [16:22:55 WARN]: at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:67)
    19.06 16:22:55 [Server] INFO [16:22:55 WARN]: Caused by: java.lang.ClassNotFoundException: net.minecraft.server.v1_7_R3.World
    19.06 16:22:55 [Server] INFO [16:22:55 WARN]: at net.minecraft.server.v1_7_R2.ThreadServerApplication.run(SourceFile:618)
    19.06 16:22:55 [Server] INFO [16:22:55 WARN]: at net.minecraft.server.v1_7_R2.MinecraftServer.run(MinecraftServer.java:459)
    19.06 16:22:55 [Server] INFO [16:22:55 WARN]: at net.minecraft.server.v1_7_R2.MinecraftServer.u(MinecraftServer.java:548)
    19.06 16:22:55 [Server] INFO [16:22:55 WARN]: at net.minecraft.server.v1_7_R2.DedicatedServer.v(DedicatedServer.java:250)
    19.06 16:22:55 [Server] INFO [16:22:55 WARN]: at net.minecraft.server.v1_7_R2.MinecraftServer.v(MinecraftServer.java:657)
    19.06 16:22:55 [Server] INFO [16:22:55 WARN]: at net.minecraft.server.v1_7_R2.ServerConnection.c(SourceFile:134)
    19.06 16:22:55 [Server] INFO [16:22:55 WARN]: at net.minecraft.server.v1_7_R2.NetworkManager.a(NetworkManager.java:147)
    19.06 16:22:55 [Server] INFO [16:22:55 WARN]: at net.minecraft.server.v1_7_R2.PacketPlayInChat.handle(PacketPlayInChat.java:47)
    19.06 16:22:55 [Server] INFO [16:22:55 WARN]: at net.minecraft.server.v1_7_R2.PacketPlayInChat.a(PacketPlayInChat.java:28)
    19.06 16:22:55 [Server] INFO [16:22:55 WARN]: at net.minecraft.server.v1_7_R2.PlayerConnection.a(PlayerConnection.java:814)
    19.06 16:22:55 [Server] INFO [16:22:55 WARN]: at net.minecraft.server.v1_7_R2.PlayerConnection.handleCommand(PlayerConnection.java:952)
    19.06 16:22:55 [Server] INFO [16:22:55 WARN]: at org.bukkit.craftbukkit.v1_7_R2.CraftServer.dispatchCommand(CraftServer.java:696)
    19.06 16:22:55 [Server] INFO [16:22:55 WARN]: at org.bukkit.command.SimpleCommandMap.dispatch(SimpleCommandMap.java:180)
    19.06 16:22:55 [Server] INFO [16:22:55 WARN]: at org.bukkit.command.PluginCommand.execute(PluginCommand.java:44)
    19.06 16:22:55 [Server] INFO [16:22:55 WARN]: at net.citizensnpcs.Citizens.onCommand(Citizens.java:236)
    19.06 16:22:55 [Server] INFO [16:22:55 WARN]: at net.citizensnpcs.api.command.CommandManager.executeSafe(CommandManager.java:177)
    19.06 16:22:55 [Server] INFO [16:22:55 WARN]: at net.citizensnpcs.api.command.CommandManager.execute(CommandManager.java:90)
    19.06 16:22:55 [Server] INFO [16:22:55 WARN]: at net.citizensnpcs.api.command.CommandManager.executeMethod(CommandManager.java:153)
    19.06 16:22:55 [Server] INFO [16:22:55 WARN]: at java.lang.reflect.Method.invoke(Method.java:606)
    19.06 16:22:55 [Server] INFO [16:22:55 WARN]: at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
    19.06 16:22:55 [Server] INFO [16:22:55 WARN]: at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
    19.06 16:22:55 [Server] INFO [16:22:55 WARN]: at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    19.06 16:22:55 [Server] INFO [16:22:55 WARN]: at net.citizensnpcs.commands.TraitCommands.toggle(TraitCommands.java:152)
    19.06 16:22:55 [Server] INFO [16:22:55 WARN]: at net.citizensnpcs.commands.TraitCommands.addTrait(TraitCommands.java:59)
    19.06 16:22:55 [Server] INFO [16:22:55 WARN]: at net.citizensnpcs.api.npc.AbstractNPC.addTrait(AbstractNPC.java:90)
    19.06 16:22:55 [Server] INFO [16:22:55 WARN]: at net.citizensnpcs.api.npc.AbstractNPC.addTrait(AbstractNPC.java:111)
    19.06 16:22:55 [Server] INFO [16:22:55 WARN]: at net.aufdemrand.sentry.SentryTrait.onSpawn(SentryTrait.java:116)
    19.06 16:22:55 [Server] INFO [16:22:55 WARN]: at net.aufdemrand.sentry.SentryTrait.ensureInst(SentryTrait.java:134)
    19.06 16:22:55 [Server] INFO [16:22:55 WARN]: java.lang.NoClassDefFoundError: net/minecraft/server/v1_7_R3/World
    19.06 16:22:01 [16:22:01 INFO]: Skydorm ran command Nachricht des Tages
    19.06 16:21:10 [Server] INFO [16:21:10 INFO]: [Citizens] Loaded 5 NPCs.
    19.06 16:21:10 [Server] INFO [16:21:10 INFO]: [Sentry] Could not find or register with SimpleClans.
    19.06 16:21:10 [Server] INFO [16:21:10 INFO]: [Sentry] Could not find or register with War.
    19.06 16:21:10 [Server] INFO [16:21:10 INFO]: [Sentry] Could not find or register with Factions.
    19.06 16:21:10 [Server] INFO [16:21:10 INFO]: [Sentry] Could not find or register with Towny
    19.06 16:21:10 [Server] INFO [16:21:10 INFO]: [Sentry] Could not register with Denizen
    19.06 16:21:10 [Server] INFO [16:21:10 INFO]: [Sentry] Enabling Sentry v1.8.2
    19.06 16:21:10 [Server] INFO [16:21:10 INFO]: [dtlTraders][INFO] Enabled
    19.06 16:21:10 [Server] INFO [16:21:10 INFO]: [dtlTraders][INFO] Accounts loaded: 0
    19.06 16:21:10 [Server] INFO [16:21:10 INFO]: [dtlTraders][INFO] Permission plugin: PermissionsEx
    19.06 16:21:10 [Server] INFO [16:21:10 INFO]: [dtlTraders][INFO] Registered types: [server]
    19.06 16:21:10 [Server] INFO [16:21:10 INFO]: [dtlTraders][INFO] Registered core flags: [Lore ,NoStack ,Abstract ,SplashPotion ,DataCheck ,StackPrice]
    19.06 16:21:10 [Server] INFO [16:21:10 INFO]: [dtlTraders][INFO] Registered core attributes: [GenericDamage ,PatternItem ,Name ,Book ,Skull ,Slot ,StoredEnchants ,Price ,GenericKnockback ,Potion ,Multiplier ,Enchants ,Durability ,GenericSpeed ,GenericHealth ,Leather color ,Amount ,Tier ,Firework]
    19.06 16:21:10 [Server] INFO [16:21:10 INFO]: [dtlTraders][INFO] Loading config files
    19.06 16:21:10 [Server] INFO [16:21:10 INFO]: [dtlTraders][INFO] Economy plugin: iConomy 7
    19.06 16:21:10 [Server] INFO [16:21:10 INFO]: [dtlTraders] Enabling dtlTraders v3.0.9-snapshot
    19.06 16:21:09 [Server] INFO [16:21:09 ERROR]: [Citizens] Unable to find Rhino classes - javascript scripts won't see non-CraftBukkit classes
    19.06 16:21:09 [Server] INFO [16:21:09 INFO]: [Citizens] Enabling Citizens v2.0.12-SNAPSHOT (build 1114)

    Ich hab einfach mal alles dringelassen was mit npc's zu tun hat. Dass sollte Nützlich sein, schätz ich zumindest.
     
    #1
  2. Watteschaf
    Offline

    Watteschaf

    Registriert seit:
    2. November 2013
    Beiträge:
    30
    Code (Text):
    1. java.lang.NoClassDefFoundError: net/minecraft/server/v1_7_R3/World
    Das Plugin verwendet Minecraft-Server-Klassen. Deine Server-Version ist scheinbar nicht die gleiche wie die des Plugins.
     
    #2
  3. skyshiny99
    Offline

    skyshiny99

    Registriert seit:
    2. Oktober 2012
    Beiträge:
    32
    Etwas mehr Informationen bitte ;)

    Version des Servers, des Citizens- und des Sentry-Citizens-Plugins?
     
    #3
  4. Skydorm
    Offline

    Skydorm

    Registriert seit:
    23. Mai 2014
    Beiträge:
    36
    version des servers: 1.7.5
    version von citizens: 1.7.5 so wie sentry-citizens (sonst würde es doch nicht laufen oder?)
     
    #4
  5. MrPyro13
    Offline

    MrPyro13

    Registriert seit:
    29. April 2013
    Beiträge:
    829
    Minecraft:
    MrPyro13
    Hallo,

    kommt beim Starten des Servers eine Fehlermeldung oder nur dann, wenn du den Befehl eingibst?
     
    #5
  6. Watteschaf
    Offline

    Watteschaf

    Registriert seit:
    2. November 2013
    Beiträge:
    30
    Citizens 1.7.5. gibts nicht. Aktuell ist Alpha 2.0.13 für CB 1.7.9
    Edit: Sehe schon in deiner Fehlermeldung das es 2.0.12 ist. Wichtig wäre dann die Sentry-Version zu wissen.

    Sentry Version 1.7.5. sollte es ebenso nicht sein... Version 1.8.1 oder 1.8.2 (das sind die beiden aktuellsten Sentry-Versionen)?
     
    #6