ServerPlugin Trank Partikel und Ähnliche.

Dieses Thema im Forum "Programmierung" wurde erstellt von 2801MC, 25. Februar 2015.

  1. 2801MC
    Offline

    2801MC

    Registriert seit:
    15. August 2013
    Beiträge:
    77
    Ich habe einen Code um Partikel zu machen:

    Code (Text):
    1. public boolean onCommand(CommandSender sender, Command cmd, String label, String[] args){
    2.         if(cmd.getName().equalsIgnoreCase("partikel")){
    3.             if(sender instanceof Player){
    4.                 Player p = (Player) sender;
    5.                 p.playEffect(p.getLocation(), Effect.STEP_SOUND, 7);
    6.             }
    7.         }
    8.         return false;
    9.     }
    Damit werden bei der Spieler Position Partikel von einem Zerstörtem Bedrock-Block erzeugt.
    Aber ich brauche Trank-Partikel oder diese kleinen weißen Sterne von Raketen. Kann mir jemand erklären wie das geht?
    EDIT:
    Ich weiß jetzt wie das geht, aber habe ein anderes problem mit dem Plugin!
    Es wird nicht geladen.
    Code (Text):
    1. [Server thread/ERROR]: Could not load 'plugins/Partikel.jar' in folder 'plugins'
    2. org.bukkit.plugin.InvalidPluginException: java.lang.UnsupportedClassVersionError: de/rpgcreeper/effects/MCEffects : Unsupported major.minor version 52.0
    So wie ich es verstehe ist da irgendwas mit einer Falschen version. Auf meinem Testserver (der is auf meinem eigenem PC) da geht alles Perfekt, aber auf meinem richtigem Server bekomme ich diesen Fehler! Die sind beide auf der 1.7.9!

    EDIT:
    Danke für jede Hilfe die vieleicht noch gekommen wäre, aber ich habe es schon alles selbst geschafft!
     
    #1
  2. [Dev] iTzSasukeHDxLP
    Offline

    [Dev] iTzSasukeHDxLP Ehem. Teammitglied

    Registriert seit:
    5. Januar 2014
    Beiträge:
    938
    Für die Zukunft und Andere: Sieht so aus als hätten du (Client) und deine Laufzeitumgebung (auf dem Server) unterschiedliche Java Versionen. Diese sollte man immer aktuell halten, was mittlerweile Java 8 bedeutet.
     
    #2
  3. 2801MC
    Offline

    2801MC

    Registriert seit:
    15. August 2013
    Beiträge:
    77
    Ich habe Java 8, aber für meinen Server musste ich das Plugin mit Java 7 machen!
     
    #3
  4. Eisphoenix
    Offline

    Eisphoenix

    Registriert seit:
    9. Oktober 2014
    Beiträge:
    82
    Ort:
    Garmisch-Partenkirchen
    Minecraft:
    Eisphoenix
    Wenn man mit Java 7 komplimentiert, so funktioniert es auch mit Java 8, aber leider :( nicht umgekehrt, weswegen du entweder Java 7 auf deinem Pc benutzt oder Java 8 auf dem Server
     
    #4