UTF-8 Problem

Dieses Thema im Forum "Server Plugins" wurde erstellt von fs626, 9. März 2014.

  1. fs626
    Offline

    fs626

    Registriert seit:
    24. Juli 2012
    Beiträge:
    193
    Ort:
    Deutschland
    Hallo, ich habe gestern meinen Root Server geupdatet mit apt-get update / upgrade. Nachdem ich ihn daraufhin neu gestartet hatte, und meinen Minecraft Server startete, bemerkte ich, dass etliche Configs (mit UTF-8) nicht mehr geladen wurden. Hier ein Beispiel:
    Code (Text):
    1. [01:31:17] [Server thread/ERROR]: Cannot load plugins/FancyTab/config.yml
    2. org.bukkit.configuration.InvalidConfigurationException: expected '<document start>', but found BlockMappingStart
    3.  in 'string', line 49, column 1:
    4.     logConsole: true
    5.     ^
    Daraufhin habe ich die Config mal gelöscht und neu erstellen lassen, danach wurde sie geladen (mit ANSI). Doch wenn ich meine Configs in wieder UTF-8 speichere, dann kommt wieder der oben genannte Error.

    Hoffe ihr könnt mir helfen.

    MfG
     
    #1
  2. RaphixxYT
    Offline

    RaphixxYT Gesperrt

    Registriert seit:
    16. Dezember 2013
    Beiträge:
    54
    Ort:
    Nürnberg
    In Linux gibt es eigentlich kein UTF 8. Das merke ich immer wieder in meinen datenbanken. Wenn ich die ä ö ü und so nicht manuell umstellen funktioniert es nicht. Probiere doch mal die HTML ASCI codes. Weiß aber nicht ob das funktioniert oder nicht.
     
    #2